Degradation - Service Extensions Across All Regions

Incident Report for Strata Identity

Resolved

Our Engineering team has resolved the issue affecting Service Extensions. Customers across all regions may have experienced failures or inconsistent behavior when attempting to save Service Extension usages. This issue has now been resolved and functioning normally. If you continue to experience problems, please contact our support team. We apologize for any inconvenience.
Posted Mar 05, 2026 - 22:48 UTC

Update

Our Engineering team has identified the cause of the issue impacting Service Extensions across all regions and is actively working on a fix. Deployment to lower environments is currently delayed due to a third-party CI/CD disruption caused by an ongoing GitHub incident. We are monitoring the GitHub situation closely and will deploy the fix as soon as services are restored. We will post further updates as progress is made.
Posted Mar 05, 2026 - 16:49 UTC

Identified

Our Engineering team has identified the cause of the issue impacting Service Extensions across all regions and is actively working on deploying a fix. Users may continue to experience failures or inconsistent behavior when attempting to save Service Extensions during this time. We will post further updates as soon as the fix is deployed.
Posted Mar 04, 2026 - 22:43 UTC

Investigating

Our Engineering team is investigating an issue impacting Service Extensions across all regions. Users may experience failures or inconsistent behavior when attempting to save Service Extensions. Symptoms may vary depending on the specific extension type, but the underlying issue appears to be platform-wide. We apologize for the inconvenience and will share an update once we have more information.
Posted Mar 04, 2026 - 18:26 UTC
This incident affected: North America - United States (Maverics Console) and Europe - United Kingdom (Maverics Console).