Degradation - Orchestrator Telemetry

Incident Report for Strata Identity

Resolved

Our Engineering team has resolved the issue affecting Orchestrator Telemetry. Customers across all regions may have experienced degraded or missing telemetry data during this time. All services should now be functioning normally. If you continue to experience problems, please contact our support team. We apologize for any inconvenience.
Posted Mar 06, 2026 - 04:05 UTC

Investigating

Our Engineering team is investigating an issue impacting Orchestrator Telemetry across all regions. Users may experience degraded or missing telemetry data during this time. We apologize for the inconvenience and will share an update once we have more information.
Posted Mar 05, 2026 - 22:22 UTC
This incident affected: North America - United States (Maverics Console) and Europe - United Kingdom (Maverics Console).